DiVa software on Intel Mac problem

Katherine Pilkington katherine.pilkington at imvs.sa.gov.au
Thu Jan 4 17:03:46 EST 2007


Hi Pam and Richard,


I could be shooting wide of the mark here - but I suspect I have experienced
this problem before myself.


Every time I re-install the DiVa software (which is disturbingly often, as
many of the problems encountered with the software etc seem to be corrected
by a re-install!) I get a similar message.  I too spent several days
investigating SQL (Sybase) etc but after some persistence I eventually got
an answer from BD, who I believe had to first recreate the problem on their
own computer and then devise a solution.


I think that you need to edit your cmdbdfacs.bat batch file (I only work
with PCs, so don't want to vouch for MACs.)  This file is located in the
following directory - C:\Program Files\BD FACSDiva Software.  Right click on
the cmdbdfacs.bat, select properties from the context menu and deselect the
radio button beside read only - this will enable you to edit the batch file.
Then right click again on the batch file and select edit - a notepad window
will automatically open with a load of computer jargon text in it - find
lines 21 and 22, they should look something like this


  set maxHEAP=1400

  ) else set /a maxHEAP=%pmem%/10*7/1048576


There are a couple of possibilities to try to get your software to work -
first replace the 1400 on line 21 with a 1200, and also alter the 10*7 to
10*6 - now attempt to open your software, if it still does not work, try
replacing the 1400 with 1000 and replace the 10*7 with 10*5.  Again try to
open your software.  If neither of this alternatives work for you, be
ABSOLUTELY certain to return your batch file to its original format and
start riding the tails of your local BD guys again.  If you have any further
questions, or have any difficulties with editing the bat file, let me know
and I can send you a "pre-edited" version of the file that you can use to
replace the original. 


Good luck, and happy flowing.


Kat


--

Katherine Pilkington

Flow Cytometrist and Cell Sorter

Detmold Family Imaging Centre

Institute of Medical and Veterinary Science 

Frome Road, Adelaide South Australia 5000

Ph: +61 8 8222 3322


  _____  

From: Pamela Shaw [mailto:pamela.shaw at umontana.edu] 
Sent: Thursday, 4 January 2007 9:28 AM
To: cyto-inbox
Subject: RE: DiVa software on Intel Mac problem


Hi Richard,


I am not so sure your problem is caused by using an Intel IMac.  I have
tried installing DIVA 5.0.1 on two different computers.  It loaded fine on a
laptop PC with Windows XP that we use just for analysis.  However, when I
tried to load it on our HP computer with Windows 2000 that is attached to
the instrument (FACSAria) I got similar error messages as you and could not
get it to work.  I called BD and asked if the problem was the Windows
version.  That was in September.  I have called them repeatedly and still
have not got an answer from them.  If you get an answer that addresses the
Sybase issue that does not appear on this post, would you mind forwarding it
to me?


Not so long ago, I had asked for advice on this site with loading DIVA on an
Intel IMac.  I had several folks respond that they were able to do so with
success.  I thank all who took the time to share their experience with me.
We have not had a chance to try it yet, but hope to soon.  First we need to
get it to work on the acquisition computer!


Good luck,



Pam Shaw

Fluorescence Cytometry Core Facilitator

Center for Environmental Health Sciences

The University of Montana

32 Campus Dr, Skaggs Building 052

Missoula, MT 59812


Ph (406) 243-4974

email:	 <mailto:pamela.shaw at umontana.edu> pamela.shaw at umontana.edu

www.umt.edu/cehs <http://www.umt.edu/cehs/FluorCytomCore.htm>
/FluorCytomCore.htm


-----Original Message-----
From: Richard D. Schretzenmair [mailto:rds at mail.med.upenn.edu] 
Sent: Wednesday, January 03, 2007 9:09 AM
To: cyto-inbox
Subject: DiVa software on Intel Mac problem


Hello,


We have tried installing either DiVa 5.0.1 or 5.0.2 on and Intel IMac using
Windows XP and Parallels, for analysis only. The USB ports are turned on,
with Auto-mount. When the dongle is inserted windows reports that a new
device has been mounted. We encountered the following errors during
installation:


1) Choose Cytometer dialog:  While it defaults to None, it will not accept
that response as an answer, and forces you to pick a instrument.


2) On the advice of our engineer, we picked an instrument. Installation
continues, as expected VxWorks fails to load, then the installer reports
that FACSDiva software was successfully installed.


Then when we launch the DiVa software, the following error message appears:


	  &nbs p; Drive initialization error occurred

	  &nbs p; Application will be terminated

	  &nbs p; Status value 12


When we clear that window a console window appears with the following
message:


	  &nbs p; Error starting the application

	  &nbs p; Check log...


Checking the log:


	  &nbs p; Disabling offscreen DirectDraw acceleration


	  &nbs p; It is likely that your Database is not running.

	  &nbs p; Ensure 'SyBase' has been installed and the service is
running


	  &nbs p; Go to

	  &nbs p;	      Control Panel/Administrative Tools/Services

	  &nbs p;	      and see if the following service exists and is
started:

	  &nbs p;	      Adaptive Server Anywhere - BDFACSApp


Admin. Tools reports that the service exists and is indeed active. For good
measure I stopped and restarted this service. The DiVa software still fails
to launch, with the same error message. Does anyone one have any suggestions
for how to work around this problem?


Thanks for your help


Rich



Richard D. Schretzenmair


Flow Cytometry and Cell Sorting Shared Resource

Abramson Cancer Center

University of Pennsylvania School of Medicine

297 John Morgan Bldg.

3620 Hamilton Walk

Philadelphia, PA  19104-6082


Phone:	215-898-3528

FAX:	215-898-4227


rds at mail.med.upenn.edu



-------------- next part --------------
HTML attachment scrubbed and removed


More information about the Cytometry mailing list